100916


一种粗选跟踪标的的方法





一直想编写一个指标用来快速评估一个品种是否值得跟踪(根据历史数据),关于这方面的
思考经历了下面几个阶段。
1
考虑品种的长线波幅(越大越好)
2
考虑品种的连续性(C-C波动越小越好)
3
将前两点用一个算法综合考虑(发现结果与实践经验不符,说明考虑因素不完备)
4
考虑
行情的流畅性(拐点数量越少越好)
5
考虑时间因素
到了这里我发现已经无法综合考虑并合理量化这么多因素了。于是转换思路,像是写失败指标一样,如果从行情特征出发来界定整理的强度非常困难,那就观察一个标准
趋势跟踪系统输出绩效中的一些信息来得到结论。同样的,这里可以用一个标准趋势跟踪系统收益率的年化值来反映上面这5个因素。选择的标准趋势跟踪系统20日单均线跟踪系统,选择的一些依据在先前关于失败指标的一些文章中有提及。(适合作为期货股市标准趋势跟踪系统,但不适合外汇市场,汇市需要另定参数。)
文华代码如下(参数MACLOSE=20START=1):
BB:=BARPOS;
B1:=IFELSE(CLOSE>MA(CLOSE,MACLOSE)*1.00,1,0);
S1:=IFELSE(CLOSE<MA(CLOSE,MACLOSE)*1.00,1,0);
S2:=IFELSE(B1=0&&S1=0&&(BARSLAST(S1)-BARSLAST(B1))<0,1,0);

B2:=IFELSE(S1=0&&B1=0&&(BARSLAST(S1)-BARSLAST(B1))>0,1,0);

S:=S1+S2;
B:=B1+B2;
SD:=BARSLAST(REF(B,1));
BD:=BARSLAST(REF(S,1));
SR:=IFELSE(S=1&&BB>START&&REF(S,1)=0,CLOSE/REF(CLOSE,BD)-1,0);

SR1:=IFELSE(S=1&&BB>START&&REF(S,1)=0,CLOSE-REF(CLOSE,BD),0);

SR2:=IFELSE(BB>260,CLOSE/REF(CLOSE,BD)-1,0);
LASTS:=IFELSE(ISLASTBAR,CLOSE/REF(CLOSE,BD)-1,0);
BR:=IFELSE(B=1&&BB>START&&S=0&&REF(B,1)=0,REF(CLOSE,SD)/CLOSE-1,0);

BR1:=IFELSE(B=1&&BB>START&&REF(B,1)=0,REF(CLOSE,SD)-CLOSE,0);

BR2:=IFELSE(BB>START&&S=0,REF(CLOSE,SD)/CLOSE-1,0);

LASTB:=IFELSE(ISLASTBAR,REF(CLOSE,SD)/CLOSE-1,0);
TP1:=(SUM(SR1,0)+SUM(BR1,0));
TP2:=SUM(SR,0)+SUM(BR,0);
TP:=TP1/N3*100;
TN:=COUNT(SR<>0,0)+COUNT(BR<>0,0);

SR11:=IFELSE(SR>0,SR,0);
SR12:=IFELSE(SR<0,SR,0);
BR11:=IFELSE(BR>0,BR,0);
BR12:=IFELSE(BR<0,BR,0);
C1:=COUNT(SR>0,0);
C2:=COUNT(BR>0,0);
C3:=COUNT(SR<0,0);
C4:=COUNT(BR<0,0);
T1:=SUM(SR11,0);
T2:=SUM(BR11,0);
T3:=SUM(SR12,0);
T4:=SUM(BR12,0);
AVGR:=((T1+T2)/(C1+C2))/(-(T3+T4)/(C3+C4));
DD:=(HHV(TP,0)-TP);
SRDDM:=IFELSE(BB>START,(REF(CLOSE,SD)-CLOSE),0);

BRDDM:=IFELSE(BB>START,(CLOSE-REF(CLOSE,BD)),0);

TPM:=(TP1+SRDDM+BRDDM-SR1-BR1)/(MA(CLOSE,BARPOS)-1);
Y:=BARPOS/260;
avtpm:TPM/Y;
DMC:=(HHV(TPM,0)-TPM)/HHV(TPM,0)*100;
AL:=MA(TPM,250);

将指标应用到常见标的上得到结果,记录并线性化为0~100的整数制表(数值越大表示越适合跟踪):






































品种



指标



螺纹


100



塑料


100



沪深300


100



棕榈油


87



沪胶


85



纽约银


80



燃油


77



沪锌


76



菜油


71


PVC


69


PTA


63



豆粕


62



恒生


62



豆油


60



沪铜


60



白糖


59



豆一


56



郑棉


56



沪铝


55



美玉米


55



玉米


54



沪金


54



美豆


53



11


51



纽约金


49



纽约铜


48



强麦


48



美原油


44



籼稻


43



可可


42



标普


37



美豆油


34



咖啡


0



这个结果和实践经验比较符合,当然由于标准趋势跟踪系统实际上并不存在标准,所以个别品种的优劣次序可能与实践经验略有出入,但是总体上看还是能反映问题的。再回头看本文题目一种粗选跟踪标的的方法,是什么方法呢?就是拿一个系统去把所有品种测一测,看看哪几个比较好….

我关心这个问题的原因有两点:1期货交易实践中发现一些品种很难赚到钱,希望通过品种再选择提高现在跟踪组合的盈利潜力。2正在股市上尝试运用目前做期货的策略,需要一个定量的过滤筛选大量股票的方法。



说点什么