失败指标雏形

周泓090621

(此文是后来整理的,其中的三个连续失败XX,是后来失败指标的雏形)

      系统的基础已经定了(假设上面的改动最终能使得策略与目标匹配)
      接下来在基础之上,我要再为主观构建一个层次,或者说是空间。这个层次会有很多限制,包括时间(什么时候开放主观权限),资金量(主观权限的额度),目标匹配(主观操作的目的)等等。
      暂时有一个概念,和gu兄提及过,就是“交易别人的资金曲线”。具体呢,就是找一个简单的趋势跟踪系统,独立观察它在各个市场的表现,然后采取相应的主观策略。策略主要可以有两类:1是盈冲,比如统计这个独立系统的“风报比=平均单比亏损幅度/平均单比盈利”,对这个风报比做长短两根X、Y日均线平滑,那么金叉主观入场==实现赢冲。2是输冲(我对这个更喜欢),比如统计这个独立系统的下面这些指标:
连续失败次数
连续失败天数
连续失败的累计亏损
根据这三项做一个模糊算法的指标。实现输冲,会有比较高的胜率。

这里关于“交易别人的资金曲线”有几个基本问题。
首先,虽然号称是交易“资金曲线”但实际没有直接用资金曲线,而是用了其系统产生的一些交易结果。比如风报比,比如连续失败次数等。这样做的原因是我觉得曲线是综合的结果,要使得自己的目标和策略有良好的匹配,需要寻找概率优势的本源,这些指标虽然不能说是本源,但是更接近一些。
第二,为什么不考虑交易“自己”的资金曲线呢,因为这会产生类似循环迭代的效果,丢失概率优势的本源。
第三,这个说来容易,真的做的话,到哪里找这个绝对客观的“别人”呢?系统测试是一个办法,但是20多个品种,行情一直在发展,难免顾此失彼。或许每个季度做一遍测试,当发现市场已经连续好几个季度盘整的时候,开仓进入是个不错的选择,可是退出又比较茫然了。我编了几个指标,可以实时统计“连续失败次数、连续失败天数、 连续失败的累计亏损”,也可以和历史做对比。

 
这个图是收盘线+交易信号。上面的参数依次是,收盘价,ATR,连续失败次数,连续失败天数, 连续失败的累计亏损


这个图是连续失败次数(白),连续失败天数(黄), 连续失败的累计亏损(绿)的指标线
我选的“标准”系统是20单线跟踪。可以看到,对于橡胶,上述三个指标目前同时创出了历史新高。
第四,作了一个简单的数据录入小程序,方便录入到excel,最终做成一目了然监控市场的图表



上面图中的错数错日之类的,就是我对连续失败次数之类的简称

 

附:三个“失败指标”的文华算法:
BB:=BARPOS;
B:=IF(CLOSE>MA(CLOSE,20),1,0);
S:=IF(CLOSE<MA(CLOSE,20),1,0);
SD:=BARSLAST(REF(B,1));
BD:=BARSLAST(REF(S,1));
SR:=IF(S=1&&BB>50&&B=0&&REF(S,1)=0,CLOSE/REF(CLOSE,BD)-1,0);
SR1:=IF(S=1&&BB>50&&REF(S,1)=0,CLOSE-REF(CLOSE,BD),0);
SR2:=IF(BB>50,CLOSE/REF(CLOSE,BD)-1,0);
LASTS:=IF(ISLASTBAR,CLOSE/REF(CLOSE,BD)-1,0);
BR:=IF(B=1&&BB>50&&S=0&&REF(B,1)=0,REF(CLOSE,SD)/CLOSE-1,0);
BR1:=IF(B=1&&BB>50&&REF(B,1)=0,REF(CLOSE,SD)-CLOSE,0);
BR2:=IF(BB>50&&S=0,REF(CLOSE,SD)/CLOSE-1,0);
LASTB:=IF(ISLASTBAR,REF(CLOSE,SD)/CLOSE-1,0);
TR := MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
SSS:=IF(S<>REF(S,1),0,SD+BD);
ZX:=IF(SR>0&&S<>REF(S,1),1,0);
ZC:=IF(BR>0&&S<>REF(S,1),1,0);
ZZ:=ZX+ZC;
ZD:=BARSLAST(ZZ)-SSS;
AA:=IF(ZD>0,0,1);
AD:=BARSLAST(AA);
SRBR:=IF(BB>(BARPOS-AD),SR1+BR1,0);
TT2:=IF(SRBR<0,1,0);
{依次显示收盘价、ATR、显示连续亏损次数、连续亏损时间、连续亏损幅度}
BY1:=INTPART(CLOSE);
BY2:=INTPART(MA(TR,14)),COLORYELLOW;
IF(BB>(BARPOS-AD),INTPART(COUNT(TT2,AD)),0);
BARSLAST(ZZ)-SSS;
IF(BB>(BARPOS-AD),INTPART(SUM(SRBR,AD)/MA(CLOSE,320)*100),0);
我用过不同公司下载的文化,发现很怪,对同一个函数的源代码不一样。上面的代码在国泰君安期货那里下载的文华里有效。

说点什么